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DSP2 & DSP5 Custom Operating System Tutorial

EFILive V7 Tuning Tool

Important – Please Read First
This tutorial assumes you are running EFILive V7.5.5 Build 72 or later, please
ensure you are running the latest software, free updates can be downloaded from
http://www.efilive.com/
To obtain the version number of the tuning software you have installed, go to the
Help > About menu option. You must have V7.5.5 Build 72 or higher.

Your V1 hardware must also be either licensed as Flashscan Commercial or
Workshop. If you presently own a Flashscan V1 Personal cable you will need to
upgrade to use the DSP programs.
The Custom Operating Systems supplied by EFILive are provided “as is” without
warranty of any kind. Please take all reasonable caution when using the extended
features of EFILive’s Custom Operating Systems.
You may return your ECM to its GM factory condition at any time, by reflashing a
stock GM Operating System and calibration over the top of any EFILive Custom
Operating System.
To use the updated DSP5 tune switching from the V2 hardware feature you must
also have upgraded your V2 hardware to FlashScan firmware: V2.05.18 or later.
To do this you must also download the EFILive 8.1 software which is used to
update the V2 firmware. This is available with installation instructions from this link
- http://www.efilive.com/
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What is EFILive DSP?
EFILive DSP (Duramax Switchable Performance) ECM (Engine Control Module)
operating systems are modified versions of the factory ECM operating systems
that give users the ability to use the factory ECM to perform functions beyond what
was offered from the factory.
DSP2 is a customized ECM operating system developed by EFILive for the LB7 &
LLY Duramax Diesels.
DSP2 lets you to switch on the fly between two user programmable tunes; DSP2
does this by allowing you create two versions of the main operating maps that
control engine performance and are then selected via a hardwired switch.
DSP2 also offers you the feature of a switchable output using a spare pin on the
ECM. This could be used for a variety of things, such as, switching a relay on/off,
turning on a warning lamp under conditions that you can define (see hints on the
last page of this document).
DSP5 is similar to DSP2 except we expanded the number of switchable tunes
from two positions to five, plus an advanced staging option.
In mid 2008 EFILive updated the DSP5 functionality to allow the user to chose
between a hardwired switch or the V2 hardware sending serial data switching
messages to the ECM to select the tune the truck is running.
Please follow the steps on the following pages to successfully upgrade your
Duramax ECM to DSP.

support@efilive.com
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Time to upgrade the ECM to DSP
Using the EFILive Tune Tool program you can either open the file to be converted
to DSP off your computer hard drive, or read the tune from the ECM (on the
vehicle or using a bench harness).
Read ECM icon:

Select either LB7 or LLY ECM Type:

Once the file has been read from the ECM you should save this as the stock file in
case you need to return the ECM back to standard.
support@efilive.com
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With the tun file now in the editor, you need to click on the Tab that says “Upgrade O.S”. An LLY DSP5 upgrade will be the example used below.

Select which operating system upgrade you wish to apply (only choose one), then
click the “Apply Upgrade” button.

support@efilive.com
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Now save the file with a new name, File > Save As. Maybe something like
‘Joes Base DSP5 Conversion’
Or often some people might save the file base with the VIN like so
‘1GCHK23123F123456 Base DSP5 Conversion’
Once the file has been saved with its new name you now need to close the file
down, File > Close Tuning File.
You then need to reopen the same file so EFILive will recognise the file is a DSP
converted operating system, please also take note of the new operating system
number of the DSP converted file (circled in Red) once it opens.
If the file is the enhanced DSP5 with serial data switching ability then the OS ID
(circled in Green) should show as V6. The 2007 first release DSP5 will show V5.

You will notice that the program will display many out of range warnings once the
file is reloaded, this is normal. It is because the new tables used by the switching
tune/s are blank and need to have valid data put in them.
Out of Range errors:

support@efilive.com
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Now we need to populate the new switching tune maps with some data. The easiest
way to do this is to use one of the supplied scripts and use the run script option.

You will then need to load the correct script for your operating system (this is the
number you will have noted down earlier) and it must also match the unit’s settings
for the new DSP tables (metric or imperial). The scripts are typically located My Documents\EFILive\V7\User Configuration\Scripts
To ensure you choose the correct script, on the following page is a list of the file
name of the script vs the ECM operating system.
Each script file is also labelled metric or imperial, please choose the correct one to
match the table units you have set up in the tuning tool for the DSP tables /
parameters.

support@efilive.com
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LB7
GM O.S

DSP2 O.S

Script File Name

15063376

01337601

DSP2_LB7_Early.txt (choose metric or imperial)

15097100

01710001

DSP2_LB7_Early.txt (choose metric or imperial)

15188873

01887301

DSP2_LB7_Early.txt (choose metric or imperial)

15094441

02444101

DSP2_LB7_Late.txt (choose metric or imperial)

15166853

02685301

DSP2_LB7_Late.txt (choose metric or imperial)

15186006

02600601

DSP2_LB7_Late.txt (choose metric or imperial)

15189044

03904401

DSP2_LB7_Late.txt (choose metric or imperial)

DSP5 O.S

Script File Name

15063376

01337605

DSP5_LB7_Early.txt (choose metric or imperial)

15097100

01710005

DSP5_LB7_Early.txt (choose metric or imperial)

15188873

01887305

DSP5_LB7_Early.txt (choose metric or imperial)

15094441

02444105

DSP5_LB7_Late.txt (choose metric or imperial)

15166853

02685305

DSP5_LB7_Late.txt (choose metric or imperial)

15186006

02600605

DSP5_LB7_Late.txt (choose metric or imperial)

15189044

03904405

DSP5_LB7_Late.txt (choose metric or imperial)

GM O.S

LLY list on next page…
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LLY
GM O.S

DSP2 O.S

Script File Name

15141668

04166801

DSP2_LLY.txt (choose metric or imperial)

15193885

05388501

DSP2_LLY.txt (choose metric or imperial)

15231600

05160001

DSP2_LLY.txt (choose metric or imperial)

15228758

05875801

DSP2_LLY.txt (choose metric or imperial)

DSP5 O.S

Script File Name

15141668

04166805

DSP5_LLY.txt (choose metric or imperial)

15193885

05388505

DSP5_LLY.txt (choose metric or imperial)

15231600

05160005

DSP5_LLY.txt (choose metric or imperial)

15228758

05875805

DSP5_LLY.txt (choose metric or imperial)

GM O.S

Once the chosen script is loaded, click the ‘Run’ button in the bottom left corner.
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This will automatically populate the switching tune tables with stock values.
Depending on the speed of your PC this may take a few seconds or a few
minutes.
Once the script has processed all the data, click the ‘Close’ button on the right.
The final step is to choose the tune switching method you wish to use for DSP5.
•

Hardwired Switch (wired mechanical switch)

•

Serial Data Switch (for use with V2 only, no mechanical switch needed)

This is selected from the parameter A0146.

The final step if you selected Serial Data as the switching option is to enter a
password that must be entered in to the V2 to make the ECM switch tunes. If you
have the value of 0 then there will be no password required, otherwise select any
number between 1 and 9999. (Hint, use part of your phone number or credit card
number to make it easy to remember).
Any time you want to remove the password the ECM must be reflashed with the
password set to 0.
You have just about completed the EFILive DSP upgrade.
Save the tune in a new *.tun file – use the menu option File->Save as… which will
automatically increment a sequence number on the end of the file name. Each
time you alter the calibration use File->Save as… That way you create a
sequenced history of changes, allowing you to revert to a previous file should you
need to.
This *.tun file will become your “base calibration” for the upgraded Operating
System. Always keep a copy of this file in case you need to restore your ECM to
its initial Custom Operating System state. Preferably, make a backup of it onto a
CD and store it in a safe place or Email it to a friend.
The final step is to now do an entire ECM reflash with the new DSP operating
system and calibrations. This is covered on the next page.
support@efilive.com
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Hints for in-vehicle ECM flashing:
•

Ensure your vehicle is keyed to ON (not Accy) without the engine running.

•

Turn off, or even better, disconnect any aftermarket entertainment devices,
pull radio fuse if necessary. Some aftermarket entertainment devices will
interrupt the reprogramming procedure possibly leaving the ECM in an
unrecoverable state.

•

Ensure the battery is in a good state of charge.

•

If fitted with On-Star, turn it off.

You will need to perform a ‘Full Reflash’ of your ECM to use the newly created
DSP operating system and calibrations. Once this completes successfully you will
only need to do ‘Calibration’ flashing for normal tuning procedures if using an LLY
ECM. IMPORTANT For the LB7, any time you are retuning any of the DSP
Programs #2 - #4 you will need to perform a full flash of the ECM for the changes
to be applied, Program #1 changes can be programmed using just a calibration
flash.
The EFILive Tuning Tool manual covers reflashing procedures, it is highly
recommended you also refer to that document whilst performing this programming
procedure as this covers the correct steps for performing the full ECM flash and
how to go about ECM recovery should something go wrong.
With your DSP file loaded press the button circled in the picture below.

Once the full flashing procedure finishes (approx 3-4 mins) then turn off the IGN
for at least 30 seconds to allow all the vehicle modules to fully shutdown.
Next, start the truck and ensure everything is running and operating correctly (A/C,
cruise control, etc).
Once these tests are complete you can wire up your DSP switch and DSP
programmable output (if not already done). Once that is complete you can start
tuning your DSP programs.

support@efilive.com
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Wiring the DSP2 Switch / DSP5 Valet Mode Switch
The DSP2 switch works by switching the voltage level at an ECM pin. The ECM
monitors the voltage to determine which program you wish to run.
When the switch is open, the ECM will use the factory maps, when the switch is closed
(grounded) the ECM will use the DSP2 tables.
NOTE: For the DSP5 program only, the same input and wiring is used to control the
valet mode of the ECM.

The connections to the ECM from the switch are made to the following pins –

LB7
Signal = Blue connector, pin 31
Ground = Blue connector, pin 60 or 63

LLY
Signal = Black connector, pin 1
Ground = Black connector, pin 37

support@efilive.com
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Wiring the DSP5 Switch (Hardwired Only)
The hardwired DSP5 switch works by selecting different voltages for the ECM to
measure, from these voltages the ECM can determine which program you wish to run.
Below is the suggested resistance to be used for any DSP5 switch you may wish to
design. Also shown is the approx voltage the ECM will measure for each resistance.
The switching voltages are configurable within EFILive, however, the values below give
a good even separation of switch points.
The 0.1uF capacitor shown in red is optional, it is used to reduce switch bounce (the
ECM program also includes software switch debounce).

The connections to the ECM from the switch are made to the following pins –

LB7
Signal = Blue connector, pin 69
Ground = Blue connector, pin 49

LLY
Signal = Grey connector, pin 32
Ground = Grey connector, pin 50

support@efilive.com

- 14 -

www.efilive.com

DSP2 & DSP5 Custom Operating System Tutorial

EFILive V7 Tuning Tool

Wiring the DSP Output
As well as wiring up the output, also please check the operational settings in the
DSP² Output #1 section of the *.tun file to ensure the output behaves as you
desire.
WARNING: Do not wire this output directly to heavy duty solenoids such as N2O
controls, such solenoids must be switched via a relay, permanent damage to the
ECM will occur if this is not done. Also do not use high wattage lamps, you should
only use small indicator type lamps.
Choose the ECM type and wire the output as follows.

The connections to the ECM output are made to the following pins –

LB7
Output = Blue connector, pin 39

LLY
Output = Blue connector, pin 27

support@efilive.com

- 15 -

www.efilive.com

DSP2 & DSP5 Custom Operating System Tutorial

EFILive V7 Tuning Tool

LB7 ECM Connector wiring installation

#1 – Remove TCM cover

#2 – Lift out TCM

#3 – Disconnect TCM

#4 – Remove ECM cover

#5 – Unbolt blue plug

#6 – Remove blue cover

#7 – Pins now exposed

#8 – Insert new pin/wire

#9 – Re-assemble

support@efilive.com
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LLY ECM Blue Connector removal shown below for the DSP Output.
Note: Use the same process on the ECM’s Black or Grey Connectors.
#1 - Lift Grey lever

#2 - Detatch plug

#3 - Lift grey cover

#4 - Grey cover lifted

#5 - Now removed

#6 - Remove pin lock

#7 - Remove pin filler

#8 - Keep pin lock safe

#9 – Insert new pin & wire

#10 – Push in pin to latch

#11 – Reassemble 6 & 4

#12 - Finished

The LLY ECM also has the connector pin numbers stamped on its case for
confirmation, though these can be difficult to see when the ECM is fitted to
the vehicle.
All installation photos courtesy of Tony Nostedt
support@efilive.com
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DSP5 Parameters and Tables
A0141 – DSP5 Tune Switch Delay
This parameter is used to control the ‘delay’ before switching to another tune will occur
once the switch has been changed from its current position. The timer can be set to
delay the switching up to approx 7 seconds. This is only used when using a hardwired
switch.
As an example, if the delay was set to 2 seconds and the switch was set to DSP
Program #2, the switch would need to be moved off Position #2 to any other position for
2 seconds before the ECM will switch to the new position as set by the switch. This
could be used to automatically switch to a different tune when racing. You could set it
up with a delay of 5 seconds, so soon after you leave the line you turn the DSP switch
to another tune (maybe better suited to the top end of the track) and 5 seconds later the
ECM will switch to this tune.

A0136 to A0139 – DSP5 Staging Control
DSP5 staging control can be used to limit fuel delivery amounts which in turn allows you
to control (or limit) power under certain conditions. The fuel limiting table is activated by
vehicle speed, throttle position and boost levels.
When table A0139 is active it will limit the fuel delivery amounts referenced to RPM, this
allows you to slowly and smoothly ramp out fuel as the engine RPM approaches a value
you might want to limit the engine to.
This function is useful for drag race staging by allowing you to launch at consistent RPM
or boost levels without trying to control the throttle manually.
The fuel limiting table will be bypassed once any of the parameters specified by A0136,
A0137 & A0138 are exceeded. Some examples below –
A0136 (Vehicle Speed Limit) = 2MPH
A0137 (Throttle Limit) = 60%
A0138 (Boost Limit) = 18psi
With the above values, if the vehicle speed goes above 2MPH OR the Throttle goes
above 60% AND the boost levels stay below 28psi then there will be no limiting.
If any one of the 3 parameters goes outside the limits specified then the limiting table
will be ignored. In the real world this set up (with the A0139 table set with some low
mm3 numbers) would allow you to limit boost to 18psi until the throttle went above 60%
or the vehicle speed went above 2MPH, both of which will occur once the light turns
green!
A0146 – DSP5 Switch Type
Selects between a hardwired DSP5 switch or use V2 to switch the tune via serial data
messages.
A0147 - DSP5 V2 Tune Switch Password
Enter any number between 1 and 9999 for V2 switching password, 0 = No password.
support@efilive.com
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A0140 – DSP5 Valet Mode
DSP5 valet mode forces the ECM into a form of ‘limp mode’ which could be used as a
valet mode / reduced engine power mode. This parameter must be set to enable to
allow this to function.
Once it is enabled in the tun file, the ECM will monitor the state of an external input to
determine if valet mode is to be initiated. It is highly recommended that the valet switch
is not easily accessible so it cannot be accidentally engaged.
The wiring for this switch can be found on previous pages of this document.

A0142, A0143, A0144, A0145 – DSP5 switching voltages
These parameters set up the switching points for each DSP program to become
enabled.
It works by the voltage from the switch for each tune needing to fall between each
adjacent parameter for a valid reading. So as an example only, if you set the
parameters like so –
A0142 (DSP Program #1) = 4.00V
A0143 (DSP Program #2) = 3.00V
A0144 (DSP Program #3) = 2.50V
A0145 (DSP Program #4) = 1.80V
For the non DSP Program (stock) to become enabled the switch voltage must be above
4.01V.
For DSP Program #1 to become enabled the switch voltage must be between 4.00V
and 3.01V.
For DSP Program #2 to become enabled the switch voltage must be between 3.00V
and 2.51V.
For DSP Program #3 to become enabled the switch voltage must be between 2.50V
and 1.81V.
For DSP Program #4 to become enabled the switch voltage must be between 0.00V
and 1.80V.

The Scantool
You can monitor the DSP5 switch voltage and current position using the PID’s –
GM.DSP5_VOLTS_DMA – This will show the measured voltage at the ECM pin.
GM.DSP5_TUNE_DMA – This PID will show the current tune number the ECM is using.

support@efilive.com
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Configuring the V2 for DSP5 Tune Switching
To configure the V2 for tune switching you need to have the V2 connected to your PC’s
USB port. Run the program ‘EFILive Explorer’ which is in the V8 folder.
You now need to copy on to the V2 device the following files depending on the vehicle –
LB7.pmm and AL5.pmm
OR
LLY.pmm and AL5.pmm
AND
Options.txt
This is done by following the steps below:
Note: The config file system must be formatted before you can copy the files (look for
the format button in the config tab, also see note on page 23).
•

Click on to the ‘Config Files’ Tab.

•

Locate the folder ‘\Documents and Settings\All Users\Application Data\EFILive\V8\Config’ on the
left side window field.

•

Highlight either ‘LB7.pmm’ OR ‘LLY.pmm’ depending on your vehicle type.

•

Then drag your selection in to the area shown in the picture below.

•

Do the same for the ‘AL5.pmm’ file and the ‘options.txt’ files.

Continued next page
support@efilive.com
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The file that was copied called ‘options.txt’ controls the names of the tunes that will be
shown in the V2 LCD display. You can change these from the default names to
whatever you like.
This file can be edited in a program like Notepad, do not use Word.
In Notepad follow these steps –
•

With Notepad running, go to the File menu and choose Open –

•

Locate the folder ‘\Documents and Settings\All Users\Application Data\EFILive\V8\Config’

•

Now open the options.txt file.

support@efilive.com
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With the file open scroll down to the bottom of the document until you see the following.

Now you can change any of the tune names, no more than 16 characters each and the
tune names must be on separate lines.
Once the changes have been saved you will need to copy it over to the V2 hardware as
discussed on the previous pages.

Select vehicle type on the V2
If you plan on using your V2 on the same truck then you should configure it to default to
the vehicle type you will be setting up below. To do this, from the main menu on the V2
press F4 to get to the options, then press F1 for Setup.

The press F1 again to go in to the ‘Edit Settings’ menu option.

support@efilive.com
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Once you are in the ‘Edit Settings’ menu scroll down (using the arrow keys on the V2)
until you find an item called ‘AutoPIDs’. Change this to ‘YES’ by pressing the left/right
arrows on the V2 keypad.

Then exit the setup menus by pressing the ‘Cancel’ button until you get back to the
main menu screen. Once this is done the V2 will automatically select the vehicle type on
each power up.

Next, connect the V2’s OBD-II connector to the vehicle diagnostic port and turn IGN on.

Select PID’s / Vehicle type:
Press ‘F1’ (or OK) to go in to the select PIDs menu, then choose your vehicle type by
using the arrow keys on the V2 to scroll through the list of vehicle / ECM types.
The vehicle type you choose must have had the configuration files transferred for that
vehicle / ECM type as described on page 20 of this document.

support@efilive.com
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If the PID list loaded ok the screen below should be shown.

If you attempt to select a vehicle type that the matching .pmm file has not been
transferred on to the V2 then you will see an error screen like the one shown below.

In this case an LLY Auto vehicle was selected but the Allison TCM pmm file was not
transferred on to the V2. See page 20 of this document on how to transfer the Allison
pmm file on to the V2.

Changing Tunes:
Step1: From the main menu on the V2 press F3 to get to the ‘Tuning Tool’ menu.
Once there, press F3 to enter the ‘Switchable Tunes’ menu.

Step 2: Scroll down to the desired tune and press the ‘OK’ button to enable that tune.

support@efilive.com
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Step 3: If a Password is active in the Tune file you will need to enter it in here via the
keypad and press Enter on the V2 keypad. (example of password 1234 shown). The
password will not need to be entered again unless power is removed from the V2.
Note: If your tune does not have a password defined then you will not be prompted for a
password to be entered.

If the tune file was switched successfully then you should see a confirmation message
on the screen (eg Tune #4 called Power). Once the tune is activated the ECM will save
the selected tune and always run that tune unless it is switched again from the V2. Even
removing power to the ECM will not erase the current tune state.

If the switching failed (eg wrong password, no communications with the ECM) then you
will see a message like the one below.

End Of Document
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